Problems sending emails
Incident Report for Healthchecks.io
Resolved
Email delivery is back to normal.
Posted Jun 11, 2020 - 18:58 UTC
Update
Email delivery is back to normal.
Posted Jun 11, 2020 - 18:38 UTC
Investigating
We're getting errors and timeouts back from AWS SES – investigating.
Posted Jun 11, 2020 - 18:26 UTC
This incident affected: Notification Sender.