Healthchecks.io Status

Need support?

E-mail us
Welcome to the Healthchecks.io status page. If there are interruptions to service, we will post a report here, and on our Mastodon account. 
Stability IssuesDashboard
Started:
Duration:
We're investigating intermittent failing requests on healthchecks.io.

Identified:

The HTTP request failures on https://healthchecks.io seem to be a knock-on effects of connectivity issues to our object storage provider.

We have temporarily disabled API calls that retrieve ping bodies from object storage.

Identified:

We have verified the failing requests on Healthchecks.io dashboard were indeed related to object storage availability issues. The temporary solution of disabling "get object" API calls has restored the dashboard functionality. Our object storage provider has acknowledged the issue and is working on it.

Currently on Healthchecks.io dashboard, when you view details of a recent ping you will see  a "The request body data is not yet available, please check back later." message. The request bodies are not lost, and will be available for viewing eventually.

Identified:

Our object storage provider have implemented a fix. We are currently working through a backlog of not yet uploaded ping bodies.

Resolved:

We have fully caught up with ping body backlog, and the service is now operating normally.